Last modified Feb. 11, 2019, 3:22 p.m. by Simon

Editing Part Photos

Introduction
GIMP
Rotate and Crop
Adding Canvas
White Background
Removing Shadow
Save and Export
Conclusion

Introduction

Many members submit part photos, and we are really grateful for that. However, in our Help page Submitting Images and Photos, we have defined a set of guidelines to ensure the quality of our part photos, and sadly enough, we have to reject many photos that do not satisfy these requirements. That is a waste of time.

If a photo is unsharp and out of focus, there is nothing you can do about it. But mostly, with a little editing, you can turn an average image into a perfect part photo, and it will only take a minute or so. You can change the image on the left into the image on the right. This tutorial will show you how to do that.

(Click on any of the images to open an HD image in a new browser tab. Click again anywhere on that image to zoom in.)

GIMP

The program we need for the editing is GIMP, the GNU Image Manipulation Program. GIMP is a cross-platform image editor available for GNU/Linux, OS X, Windows and more operating systems. It is free software, you can change its source code and distribute your changes. Whether you are a graphic designer, photographer, illustrator, or LEGO photographer, GIMP provides you with sophisticated tools to get your job done.

The current stable release of GIMP is 2.10.8, which can be downloaded from the GIMP website. For this tutorial I am using the previous stable version, GIMP 2.8, which can be downloaded here. This version is by default included in almost all Linux distributions, it is a little less complex, and for what we want to do, it works perfectly. If you want to use GIMP 2.10 instead, go right ahead.

  • STEP 0: Download GIMP and install it.

  • STEP 1: Open your image file.

Click File > Open, navigate to your photo, and press Open.

Rotate and Crop

The part in the image is slightly tilted to the right, so we need to rotate the image first. Then we'll crop it, cutting a way most of the background.

  • STEP 2: Rotate your image.

Select the Rotate Tool, then click in the center of the part, then drag the cursor to rotate the part.

  • STEP 3: Crop your image.

Select the Crop Tool, then drag around the part leaving a small edge of background, then click in the dragged area to confirm the crop.

Adding Canvas

A part photo should be square, but the result of the crop is a rectangle. To make the image square againwe need to enlarge the canvas and then make the layer fit the canvas.

  • STEP 4: Square th image.

Click Image > Canvas Size, then, if width is smaller, make the width the same as the heigth, or, if heigth is smaller, make the heigth the same as the width. Click Center and then click Resize.

  • STEP 5: Adjust the Layer.

Click Layer > Layer to Image Size.

White Background

Now we will replace the light gray brackground by a perfect white background. We first create a new layer with background color white, and then we eraze the background of the part, making it transparent, so it will be replaced by the white background layer.

  • STEP 6: Create Background Layer.

On the right side of the screen, in the Layer Panel, right-click and select New Layer. If you want, set the Layer Name to Background, set Layer Fill Type to Background Color and click OK. Then drag the Background Layer down below the image layer, and click on the image layer to re-select it.

  • STEP 7: Eraze Image Background.

Select the Fuzzy Select Tool. Then click anywhere on the background. A dotted line will surround the part, leaving only parts and it shadow unselected. If the dotted line eats into the part, reduce the sensitivity by lowering the threshold. Press Delete to erase the selected area.

Removing Shadow

The part starts to look pretty good, but we still have to remove the shadows below the part. We could use the Fuzzy Select for this, and just repeat the previous step a couple of times; but the Fuzzy Select doesn't leave sharp edges, and we want the edges of the part as sharp as possible. So we're going to use the Eraser Tool.

  • STEP 8: Eraze the Shadows.

Select the Erazer Tool, then select a Hard Brush and, if needed, Change the Brush Size. Use ctrl-mouse-scroll-wheel to zoom in, press Space and drag mouse to pan. Position the erazer circle against the corner of the part, press shift and drag the eraser circle to the next corner of the part. Then left-click to erase the line.

  • STEP 9: Eraze More Shadows.

Reposition the viewing area and repeat the previous step: use ctrl-mouse-scroll-wheel to zoom in or out, press Space and drag mouse to pan. Position the erazer circle against the next corner of the part, press shift and drag the eraser circle to the adjacent corner of the part. Then left-click to erase the line.

  • STEP 10: Eraze Final Shadows.

If you still have some shadow remnant left over, simply drag the eraser over the area while pressing the left mouse button.

Save and Export

We're done! Only thing we still need to do is to Save and Export our image.

  • STEP 11: Save and Export.

Click File > Save and save the image as a xcf file so you can edit it later if needed. Press Save to confirm. The click File > Export and export the image as a png using the default settings.

Conclusion

The basic techniques described above can also be used to improve the quality of MOC photos. By removing the background, the MOC will look larger and the viewer is not distracted by background details. As the main subject of the photo (part or MOC) has its own layer, we can also perform small changes in brightness, contrast and color distribution, without affecting the background.

In the example below, on the left, you see an original photo of set 71043-1 that I used for my review, Hogwarts - An (in)Complete and (un)Reliable Guide. As you can see, I used white cardboard as a background, and due to the size of the model, I could barely cover the entire model. Even using three 500 W incandescent lights was not enough prevent the background from becoming light gray. Using Fuzzy Select I was able to create the image on the right. It is not perfect, there are still some remnants of shadows, if you look closely, but the final result, in my opinion, looks great.

If, after reading the tutorial, you have any questions, feel free to post them in our Forum.